光明选股,中长期指标,稳健型指标

MA1:=MA(CLOSE,5);
MA2:=MA(CLOSE,10);
MA3:=MA(CLOSE,20);
MA4:=MA(CLOSE,60);
DIF:=EMA(CLOSE,SHORT)-EMA(CLOSE,LONG);
DEA:=EMA(DIF,MID);
MACD:=(DIF-DEA)*2,COLORSTICK;
买入线:=-0.1;
追涨线:=0.1;
正趋势:=MACD >0;
异动率:=(MACD-REF(MACD,1))/REF(MACD,1),NODRAW;
A:=IF(异动率<-2,-1,异动率);
B:=IF(异动率>2,1,A);
{股票公式下载YaoYuanBa.cn}
异动率曲线:=IF(异动率>0,B,A);
空头:=(MA1<MA2<MA3);
空头2:=IF(空头,正趋势,空头);
异动:=CROSS(异动率,0) && 正趋势&&空头2&&异动率>=0.9;
初级底:IF((DIF>=0&&异动),异动,0);
中等行情底:IF((DIF<=-0.5&&异动),异动,0);
历史大底:IF((DIF<=-0.8&&异动),异动,0),COLORRED;

DRAWTEXT(异动,0.4,'异动'),COLORYELLOW;
DRAWTEXT(初级底,0.6,'初级底'),COLORLIRED;
DRAWTEXT(中等行情底,0.8,'中等行情底'),COLORGREEN;
DRAWTEXT(历史大底,1,'历史大底'),COLORRED;
 

光明选股,中长期指标,稳健型指标

猜你喜欢