【箱体量能】主图指标 源码

【箱顶】:PEAK(CLOSE,10,1)*0.98,LINETHICK5;
【箱底】:TROUGH(CLOSE,10,1)*1.02,LINETHICK5;
【箱高】:100*(【箱顶】-【箱底】)/【箱底】,NODRAW;
VAR1:=EMA(C,3);

VAR2:=EMA(C,5);

VAR3:=EMA(C,10);

VAR4:=EMA(C,20);

VAR5:=EMA(C,30);

VAR6:=(VAR2+VAR3+VAR4+VAR5)/4;

VAR7:=(VAR6-REF(VAR6,15))/REF(VAR6,15)*100;

VAR8:=(VAR6-REF(VAR6,15))/REF(VAR6, 15)*100;

VAR9:=EMA(VAR7,8);

STICKLINE(VAR7<1*REF(VAR7,1),H,L,0,0),COLORBLUE;{蓝-持币}

STICKLINE(VAR7<1*REF(VAR7,1),O,C,3, 1),COLORBLUE;

STICKLINE(VAR7>1*REF(VAR7,1),H,L,0,0),COLORRED;{红-持股}

STICKLINE(VAR7>1*REF(VAR7,1),O,C,3, 1),COLORRED;

STICKLINE(VAR7<1*REF(VAR7,1) AND VAR9>1*REF(VAR9,1),H,L,0,0),COLORGREEN;{绿-洗盘}

STICKLINE(VAR7<1*REF(VAR7,1) AND VAR9>1*REF(VAR9,1),O,C,3, 1),COLORGREEN;

买进价:=((C-REF(MA(C,6),1))/6+MA(C,6))*1.004;

买进条件:=CROSS(C,买进价) AND 买进价>REF(买进价,1);

STICKLINE(买进条件,H,L,0,1),COLORWHITE,LINETHICK2;{白-买进}

STICKLINE(买进条件,O,C,3,0),COLORWHITE,LINETHICK2;

加码价:=((C-REF(MA(C,18),1))/18+MA(C,18))*1.004;

加码条件:=CROSS(C,加码价) AND 加码价>REF(加码价,1);

STICKLINE(加码条件,H,L,0,1),COLORYELLOW,LINETHICK2;{黄-加码}

STICKLINE(加码条件,O,C,3,0),COLORYELLOW,LINETHICK2;

V1:EMA(CLOSE,5);

V2:EMA(EMA(CLOSE,29)*1.01,10);

LC:=REF(CLOSE,1);

RSI:=SMA(MAX(CLOSE-LC,0),6,1)/SMA(ABS(CLOSE-LC),6,1)*100;

逃 :IF(CROSS(84,RSI) , HIGH,HIGH+1),POINTDOT,LINETHICK7,COLORYELLOW ;HIGH+1,POINTDOT,LINETHICK7,COLOR000000;

DIFF:=EMA(CLOSE,12) - EMA(CLOSE,26);

DEA:=EMA(DIFF,9);

MACD:=2*(DIFF-DEA);

A1:=BARSLAST(REF(CROSS(DIFF,DEA),1));

B1:=REF(C,A1+1)>C AND REF(DIFF,A1+1)<DIFF AND CROSS(DIFF,DEA);

A2:=BARSLAST(REF(CROSS("KDJ.K"(9,3,3),"KDJ.D"(9,3,3)),1));

B2:=REF(C,A2+1)>C AND REF("KDJ.K"(9,3,3),A2+1)<"KDJ.K"(9,3,3) AND CROSS("KDJ.K"(9,3,3),"KDJ.D"(9,3,3));

A3:=BARSLAST(REF(CROSS("RSI.RSI1"(6,12,24),"RSI.RSI2"(6,12,24)),1));

B3:=REF(C,A3+1)>C AND REF("RSI.RSI1"(6,12,24),A3+1)<"RSI.RSI1"(6,12,24) AND CROSS("RSI.RSI1"(6,12,24),"RSI.RSI2"(6,12,24));
{YaoYuanBa.cn}

C1:=BARSLAST(REF(CROSS(DEA,DIFF),1));

D1:=REF(C,C1+1)<C AND REF(DIFF,C1+1)>DIFF AND CROSS(DEA,DIFF);

C2:=BARSLAST(REF(CROSS("KDJ.D"(9,3,3),"KDJ.K"(9,3,3)),1));

D2:=REF(C,C2+1)<C AND REF("KDJ.K"(9,3,3),C2+1)>"KDJ.K"(9,3,3) AND CROSS("KDJ.D"(9,3,3),"KDJ.K"(9,3,3));

C3:=BARSLAST(REF(CROSS("RSI.RSI2"(6,12,24),"RSI.RSI1"(6,12,24)),1));

D3:=REF(C,C3+1)<C AND REF("RSI.RSI1"(6,12,24),C3+1)>"RSI.RSI1"(6,12,24) AND CROSS("RSI.RSI2"(6,12,24),"RSI.RSI1"(6,12,24));


 

【箱体量能】主图指标 源码

猜你喜欢