(主图)黄蓝带主图指标—通达信公式

(主图)黄蓝带主图指标—通达信公式  源码如下:

(主图)黄蓝带主图指标—通达信公式

M1:=7;

M2:=12;

M3:=30;

M4:=50;

M5:=99;

M6:=144;

N:=20;

N1:=7;

N2:=79;

操盘:EXPMA(CLOSE,M1);

工作:EXPMA(CLOSE,M2);

生命:MA(CLOSE,M3),LINETHICK2;

中趋:EXPMA(CLOSE,M4); 

长趋:EXPMA(CLOSE,M5); 

牛熊:EXPMA(CLOSE,M6);

VAR3P:=IF(CLOSE/REF(CLOSE,1)>1.050 AND HIGH/CLOSE<1.010 AND IF(CLOSE>REF(CLOSE,1),88,0)>0, 91, 0);

STICKLINE(VAR3P>90,L,L*0.92,1,0),COLORFF00FF;

DRAWTEXT(VAR3P>90,LOW*0.92,'追涨'),COLORFF00FF;

SS:=MA((LOW+HIGH+CLOSE)/3,5)>REF(MA((LOW+HIGH+CLOSE)/3,5),1) AND REF(MA((LOW+HIGH+CLOSE)/3,5),1)<REF(MA((LOW+HIGH+CLOSE)/3,5),2);

SC:=L<HHV(MA((LOW+HIGH+CLOSE)/3,5),13) AND H>HHV(MA((LOW+HIGH+CLOSE)/3,5),13) AND C>REF(C,1) AND C>O;

MR:=SC AND COUNT(SS,2);

买:=MR AND NOT(REF(MR,1)),COLORYELLOW;

STICKLINE(买,L,L*0.95,1,0),COLORRED;本文由同花顺公式网整理—http://www.yaoyuanba.cn/

DRAWTEXT(买,L*0.95,'必涨'),COLORRED;

A1:=3*SMA((C-LLV(L,55))/(HHV(H,55)-LLV(L,55))*1,5,1)-2*SMA((C-LLV(L,55))/(HHV(H,55)-LLV(L,55))*1,5,1),COLOR330066;

A2:=(EMA(A1,5)-REF(EMA(A1,5),1))/REF(EMA(A1,5),1)*1;

A5:=(HHV(H,60)-C)/(HHV(H,60)-LLV(L,60))*1;

JJ:=(CLOSE+HIGH+LOW)/3;

A:=EMA(JJ,10);

B:=REF(A,1); 

STICKLINE(A>B,A,B,5,0),COLORYELLOW;

STICKLINE(A<B,A,B,5,0),COLORBLUE;

M11:=EMA(CLOSE,3);

M22:=EMA(CLOSE,8);

M33:=EMA(M2,13);

M44:=EMA(M2,55);

VAR1:=EMA(M3,55);

M55:=EMA(M4,81);

M66:=EMA(VAR1,144), COLORRED,LINETHICK2;

VAR2:=(REF(HIGH,1)+REF(LOW,1))/2;

VAR3:=MA(CLOSE,N)+2*STD(CLOSE,N);

DRAWICON(CROSS(VAR2,VAR3),HIGH*1.035,2);

DRAWTEXT(CROSS(VAR2,VAR3),HIGH*1.02,'卖出'), COLORGREEN;

VAR4:=REF(CLOSE,1);

VAR5:=SMA(MAX(CLOSE-VAR4,0),N1,1)/SMA(ABS(CLOSE-VAR4),N1,1)*100;

VAR6:=CROSS(N2,VAR5);

VAR7:=FILTER(VAR6,4);

DRAWICON(VAR7,HIGH*1.035,2);

DRAWTEXT(VAR7,HIGH*1.02,'卖出'), COLORGREEN;

A7:=(2*C+H+L)/4; 

VAR10:=LLV(LOW,34); 

VAR11:=HHV(HIGH,34); 

SK:=EMA((A7-VAR1)/(VAR2-VAR1)*100,7); 

SD:=EMA(0.667*REF(SK,1)+0.333*SK,5); 

DRAWTEXT(IF(COUNT(CLOSE<REF(CLOSE,1),8)/8>6/10 AND VOL>=1.5*MA(VOL,5) AND 

COUNT(SK>=SD,3) AND REF(LOW,1)=LLV(LOW,120),1,0),LOW,'●买进') ,COLORRED; 

DRAWTEXT(IF(COUNT(CLOSE<REF(CLOSE,1),13)/13>6/10 AND 

COUNT(SK>SD,6) AND REF(LOW,5)=LLV(LOW,120) AND REF(CLOSE>=OPEN,4) AND 

REF(CLOSE>OPEN,3) AND REF(CLOSE>OPEN,2) AND REF(OPEN>CLOSE,1) AND 

OPEN>REF(CLOSE,1),1,0),LOW,'●买进'), COLORRED; 

D:=MA(CLOSE,80)-MA(CLOSE,10)/3; 

DRAWTEXT(IF(CLOSE<D AND VOL/240>MA(VOL,5)/240 AND CLOSE>REF(CLOSE,1)*1.08 

AND CLOSE<MA(CLOSE,13)*1.3,1,0),LOW,'●抄底'),COLORRED;

STICKLINE(C/REF(C,1)>1.098 AND C=H,O,C,2,0),COLORYELLOW;


猜你喜欢