(主图)通达信K线形态+缺口提示主图指标公式-线形,公式

    摘要:上市日期:FINANCE(42),NODRAW;{标缺口}LL:=REF(L,1);HH:=REF(H,1);上跳:=L>HH;下跳:=HREF(CLOSE,1)*1.095 AND CLOSE=HIGH;跌停:=CLOSE

上市日期:FINANCE(42),NODRAW;
{标缺口}
LL:=REF(L,1);HH:=REF(H,1);
上跳:=L>HH;下跳:=H<LL;
DRAWICON(上跳,L*0.9952,1);
DRAWICON(下跳,H*1.0058,2);
{涨跌停}
涨停:=CLOSE>REF(CLOSE,1)*1.095 AND CLOSE=HIGH;
跌停:=CLOSE<REF(CLOSE,1)*0.9015 AND CLOSE=LOW;
STICKLINE(涨停,O,C,1,0),COLOR00FFFF;
STICKLINE(跌停,O,C,1,0),COLORFF0000;
GJ:=(C+H+L+O)/4;
明日阻力:=L+(GJ-L)+(C-L);
明日支撑:=L+(C-GJ);
阻:REF(明日阻力 , 1),NODRAW;
支:REF(明日支撑 , 1),NODRAW,COLORRED;
STICKLINE(ISLASTBAR AND C>=阻,阻,阻,10,1),COLOR0000FF;
STICKLINE(ISLASTBAR AND C<阻,阻,阻,10,1),COLOR00FF00;
STICKLINE(ISLASTBAR AND C>=支,支,支,10,1),COLORFF00FF;
STICKLINE(ISLASTBAR AND C<支,支,支,10,1),COLORFF8800;
DRAWTEXT_FIX(C>1,0,0.02,0,'K线形态:'),COLORFFFFFF;
早晨之星:=CONST(IF((REF(CLOSE,2)/REF(OPEN,2) < 0.95 AND REF(OPEN,1) < REF(CLOSE,2) AND ABS(REF(OPEN,1)-REF(CLOSE,1))/REF(CLOSE,1)<0.03 AND CLOSE/OPEN>1.05 AND CLOSE>REF(CLOSE,2)),1,0));
黄昏之星:=CONST(IF((REF(CLOSE,2)/REF(OPEN,2) > 1.03 AND REF(OPEN,1) > REF(CLOSE,2) AND ABS(REF(OPEN,1)-REF(CLOSE,1))/REF(CLOSE,1)<0.02 AND CLOSE/OPEN<0.97 AND CLOSE<REF(CLOSE,2)),1,0));
长十字:=CONST(IF((CLOSE=OPEN AND HIGH/LOW >1.03),1,0));
垂死十字:=CONST(IF((CLOSE=OPEN AND CLOSE=LOW AND CLOSE=HIGH),1,0));
早晨十字星:=CONST(IF((REF(CLOSE,2)/REF(OPEN,2) < 0.95 AND REF(OPEN,1) < REF(CLOSE,2) AND REF(OPEN,1)=REF(CLOSE,1) AND CLOSE/OPEN>1.05 AND CLOSE>REF(CLOSE,2)),1,0));
黄昏十字星:=CONST(IF((REF(CLOSE,2)/REF(OPEN,2) > 1.05 AND REF(OPEN,1) > REF(CLOSE,2) AND REF(OPEN,1)=REF(CLOSE,1) AND CLOSE/OPEN<0.95 AND CLOSE<REF(CLOSE,2)),1,0));
射击之星:=CONST(IF((MIN(OPEN,CLOSE)=LOW AND HIGH-LOW > 3*(MAX(OPEN,CLOSE)-LOW) AND CLOSE > MA(CLOSE,5)),1,0));
倒转锤头:=CONST(IF((MIN(OPEN,CLOSE)=LOW AND HIGH-LOW > 3*(MAX(OPEN,CLOSE)-LOW) AND CLOSE < MA(CLOSE,5)),1,0));
锤头:=CONST(IF((HIGH = MAX(OPEN,CLOSE) AND HIGH-LOW > 3*(HIGH-MIN(OPEN,CLOSE)) AND CLOSE < MA(CLOSE,5)),1,0));
吊颈:=CONST(IF((HIGH = MAX(OPEN,CLOSE) AND HIGH-LOW > 3*(HIGH-MIN(OPEN,CLOSE)) AND CLOSE>MA(CLOSE,5)),1,0));
穿头破脚:=CONST(IF(((REF(CLOSE,1)/REF(OPEN,1)>1.03 AND CLOSE/OPEN<0.96 AND CLOSE<REF(OPEN,1) AND OPEN>REF(CLOSE,1))OR (REF(CLOSE,1)/REF(OPEN,1)<0.97 AND CLOSE/OPEN>1.04 AND CLOSE>REF

猜你喜欢