同花顺公式网 同花顺,同花顺公式网收录同花顺公式,同花顺公式教程。域名:YaoYuanBa.cn(遥远吧)

loadding...

(主图)夺权专家主图指标—大智慧公式

发布时间: 2017-01-11 15:45

(主图)夺权专家主图指标—大智慧公式  源码如下:

(主图)夺权专家主图指标—大智慧公式

INPUT: M(1,0,12),N(21,3,60),N1(3,3,5),ZZ(1,1,3),M10(5,1,20);

{上面这个是具体参数。}

c1:=(C+2*H+L+O)/5;

a1:=EMA((EMA(c1,1)+EMA(c1,3)+EMA(c1,5))/3,3);

a2:=EMA((EMA(c1,6)+EMA(c1,8)+EMA( c1,10))/3,3);

a3:=EMA((EMA(c1,10)+EMA(c1,12)+EMA( c1,14))/3,3);

a4:=EMA((EMA(c1,14)+EMA(c1,16)+EMA( c1,18))/3,3);

a5:=EMA((EMA(c1,18)+EMA(c1,20)+EMA( c1,22))/3,3);

a6:=EMA((EMA(c1,22)+EMA(c1,24)+EMA(c1,26))/3,3);

a:=EMA((EMA(c1,29)+EMA(c1,31)+EMA(c1,33))/3,3);

tj:=c1>a;

tj2:=c1>OPEN or c1=OPEN and c1>REF(c1,1);

STICKLINE(tj2,H,L,0.5,0),colorred;

STICKLINE(tj,O,C,8,0),color102088;

STICKLINE(tj,O,C,7,0),color102099;

STICKLINE(tj,O,C,6,0),color1020aa;

STICKLINE(tj,O,C,5,0),color1020bb;

STICKLINE(tj,O,C,4,0),color1020cc;

STICKLINE(tj,O,C,3,0),color1020dd;

STICKLINE(tj,O,C,2,0),color1020ee;

STICKLINE(tj,O,C,1,0),color1020ff;

STICKLINE(NOT(tj),O,C,8,0),colorff7700;

STICKLINE(NOT(tj),O,C,7,0),colorff8800;

STICKLINE(NOT(tj),O,C,6,0),colorff9900;

STICKLINE(NOT(tj),O,C,5,0),colorffaa00;

STICKLINE(NOT(tj),O,C,4,0),colorffbb00;

STICKLINE(NOT(tj),O,C,3,0),colorffcc00;

STICKLINE(NOT(tj),O,C,2,0),colorffdd00;

STICKLINE(NOT(tj),O,C,1,0),colorffee00;

Var2:=LLV(L,11);

Var3q:=HHV(H,25);

警戒线:= 1 ;

减仓线:= 2 ;

卖出线:= 3 ;

空头线:=1;

动力线:= EMA((C-Var2)/(Var3q-Var2)*4,4);

DRAWICON(CROSS(动力线,警戒线),h+0.01,1);

DRAWICON(CROSS(动力线,减仓线),h+0.01,3);

DRAWICON(CROSS(动力线,卖出线),H+0.01,4);

c11:=REF(C,1);

c2:=HHV(c11,2);

c3:=LLV(c11,1);

et:=HHV(c11,2);

et1:=REF(et,1);

xb:=LLV(c11,1);

xb1:=REF(xb,1);

s:=BARSLAST(C<xb and c11>=xb1);

m1q:=REF(m,1);

n9:=BARSLAST(C>et and c11<=et1);

s1:=REF(n9,1);

m2:=BARSLAST(m-n9>0 and m1q<=n1)+1;

n2:=BARSLAST(n9-m>0 and n1<=m1q)+1;

et2:=HHV(et,m2);

xb2:=LLV(xb,n2);

app:=IF(m-n9>0 and m1q<=n1,1,IF(n9-m>0 and n1<=m1q,0,2));

h11:=IF(m-n9>0,C,et2);

h2:=IF(app=1,C,c2);

h3:=IF(m-n9<0,C,xb2);

h4:=IF(app=1,C,xb2);

关键位:=IF(m-n9>0 or app=1 ,CLOSE,h3);

m1:=MA(C,3);

多空线:MA(C,8),Color00FFFF;

生命线:MA(C,21),Color00FF00;

均线变异:=IF(m1>生命线,生命线,m1);

PARTLINE(多空线,多空线<ref(多空线,1),RGB(255,0,255)),ColorFF00FF,linethick2;

PARTLINE(均线变异,均线变异>REF(均线变异,1) and 均线变异=生命线,RGB(255,0,0)),Color00FF00,linethick2;

WW:=(MA(C,3)+MA(C,8)+MA(C,15)+MA(C,34))/4;

DRAWICON(CROSS(C,WW),LOW-0.02,4);

DRAWICON(CROSS(WW,C),HIGH+0.04,5);

DRAWTEXT(CROSS(C,WW),LOW-0.02,' 开多'),Color0000FF;

DRAWTEXT(CROSS(WW,C),HIGH+0.06,' 多平'),Color8080FF;

STICKLINE(C<OPEN and REF(C,1)>REF(O,1),REF(C,1),REF(C,1),20,0),COLORFFFFFF;

DRAWTEXT(FILTER(EMA(C,40)-EMA(C,8)>0 AND EMA(C,8)/L>1.16,3),LOW-0.02,'●'),linethick3 , COLORMAGENTA;

DRAWTEXT(FILTER(EMA(C,8)-EMA(C,40)>0 AND HIGH/EMA(C,8)>1.16,3),HIGH+0.02,'●'),linethick3 ,color99ff00;


 

关于本站 | 法律声明 | 广告合作 | RSS订阅

琼ICP备13000527号-1 | 同花顺公式 | 指标公式 | 通达信指标公式 | 大智慧公式

Copyright © 湖南携景网络技术有限公司 yaoyuanba.cn All Rights Reserved.