(分时图)大单占比分时指标—大智慧公式

(分时图)大单占比分时指标—大智慧公式  源码如下:

(分时图)大单占比分时指标—大智慧公式

a1:=((((V / CAPITAL) * 100) >= 0.045));

a2:=(((V * C) / 100));

a3:=((IF((((a2 / 8) > 20) AND (C > (REF(C,1)))),a2,0)));

主力攻击:((a3 / 40)),PRECIS0,linethick3,colorWhite;

a4:=((SUM(a3,0)));

a5:=((SUM((IF((((a2 / 8) > 20) AND (C < (REF(C,1)))),a2,0)),0)));

a6:=((SUM((IF((((a2 / 8) < 20) AND (C > (REF(C,1)))),a2,0)),0)));

a7:=((SUM((IF((((a2 / 8) < 20) AND (C < (REF(C,1)))),a2,0)),0)));

a8:=((((a4 + a5) + a6) + a7));

a9:=(a4);

a10:=(a5);

a11:=((a9 - a10));

a12:=(a6);

a13:=(a7);

a14:=((((100 * a4) / a8) > 50));

机买:(((100 * a4) / a8)),PRECIS0,linethick2,colorRed;

机卖:(((100 * a5) / a8)),PRECIS0,linethick2,colorGreen;

散买:(((100 * a6) / a8)),PRECIS0,Color5555FF;

a15:=(((100 * a7) / a8));

a16:=((机买 + 散买));

STICKLINE(a14,(机买 * 1.02),(机买 * 1.1),1,0),colorYellow;

a17:=((((((100 * a4) / a8) - ((100 * a5) / a8)) > 18) AND ((((100 * a4) / a8) - ((100 * a7) / a8)) > 18)));

STICKLINE(a17,(机买 * 1.1),(机买 * 1.2),1,0),colorMagenta;

STICKLINE(a1,(机买 * 1.2),(机买 * 1.3),1,0),colorGray;

DRAWTEXT((BARSTATUS = 2),(机买 * 0.95),'●机买'),linethick2,colorRed;

DRAWTEXT((BARSTATUS = 2),(机卖 * 0.95),'○机卖'),linethick2,ColorFFFF55;

DRAWTEXT(((a11 > 0) AND ((REF(a11,1)) <= 0)),(机买 * 1.02),'●机买'),colorRed;

DRAWTEXT(((a11 < 0) AND ((REF(a11,1)) >= 0)),(机买 * 0.98),'○机卖'),ColorFFFF55;


猜你喜欢