(买卖)买卖参谋指标—大智慧公式

(买卖)买卖参谋指标—大智慧公式  源码如下:

(买卖)买卖参谋指标—大智慧公式

Var1:=HHV(HIGH,3);

Var2:=(IF(WINNER(1.1*CLOSE)<0,0,WINNER(1.1*CLOSE))-IF(WINNER(0.9*CLOSE)<0,0,WINNER(0.9*CLOSE)))*100;

Var3:=IF(Var1<0,0,Var1);

Var4:=IF(Var2<0,0,Var2);

震仓:PWINNER(10,Var4)*100,COLORWHITE,crossdot,LINETHICK1;

v1:=llv(low,10);

v2:=hhv(h,25);

价位线:=ema((c-v1)/(v2-v1)*4,4);

买入:STICKLINE(cross(价位线,0.3),50,5,2,0), COLOR00CCff,LINETHICK1;

STICKLINE(cross(价位线,0.3),30,5,2,0),colorred,LINETHICK1;

卖出:STICKLINE(cross(3.5,价位线),60,100,2,0), colorred,LINETHICK2;

STICKLINE(cross(3.5,价位线),80,100,2,0), COLORFF9900,LINETHICK2;

DRAWTEXT(CROSS(价位线,0.3),55,'买'),colorf00ff0;

DRAWTEXT(CROSS(3.5,价位线),55,'卖'),color00ff00;

Var2q:=REF(LOW,1);

Var3q:=SMA(ABS(LOW-Var2q),3,1)/SMA(MAX(LOW-Var2q,0),3,1)*100;

Var4q:=EMA(IF(CLOSE*1.3,Var3q*10,Var3q/10),3);

Var5q:=LLV(LOW,30);

Var6q:=HHV(Var4q,30);

Var7q:=IF(MA(CLOSE,58),1,0);

Var8q:=EMA(IF(LOW<=Var5q,(Var4q+Var6q*2)/2,0),3)/618*Var7q;

Var9q:=IF(Var8q>100,100,Var8q);

吸筹:STICKLINE(Var9q>-120,0,Var9q,6,1),coloryellow;

AA3:=(HHV(HIGH,21)-CLOSE)/(HHV(HIGH,21)-LLV(LOW,21))*100-10;

AA4:=(CLOSE-LLV(LOW,21))/(HHV(HIGH,21)-LLV(LOW,21))*100;

AA5:=SMA(AA4,13,8);

走势:=CEILING(SMA(AA5,13,8));

AA6:=SMA(AA3,21,8);

卖临界: STICKLINE(走势-AA6>85,98,90,15,1),COLORFFFF00;


猜你喜欢