macd背离选股公式如何编写

macd背离选股公式编写详情如下:

macd背离选股公式如何编写

{底背离,通达信版、同花顺版}

DIFF:=EMA(CLOSE,12) - EMA(CLOSE,26);

DEA:=EMA(DIFF,9);

MACD:=2*(DIFF-DEA);

QZQ:=BARSLAST(REF(MACD,1)<0 AND MACD>0);

QM:=LLVBARS(MACD,QZQ+20);

MQDZ:=IF(QM>QZQ,REF(MACD,QM),0);

XG1:=MACD<0 AND MACD>MQDZ

 AND CLOSE=LLV(CLOSE,QZQ+20) AND MQDZ<0;

XG:REF(XG1,1)=1 AND MACD>REF(MACD,1);

 

{双底背离,通达信版、同花顺版}

DIFF:=EMA(CLOSE,12) - EMA(CLOSE,26);

DEA:=EMA(DIFF,9);

MACD:=2*(DIFF-DEA);

QZQ:=BARSLAST(REF(MACD,1)<0 AND MACD>0);

QM:=LLVBARS(MACD,QZQ+20);

MQDZ:=IF(QM>QZQ,REF(MACD,QM),0);

QF:=LLVBARS(DIFF,QZQ+20);

DQDZ:=IF(QF>QZQ,REF(DIFF,QF),0);

XG1:=MACD<0 AND MACD>MQDZ AND DIFF<0 AND DIFF>DQDZ

 AND CLOSE=LLV(CLOSE,QZQ+20) AND MQDZ<0 AND DQDZ<0;

XG:REF(XG1,1)=1 AND MACD>REF(MACD,1);

 

注:底双背离是指MACD(绿柱)和DIFF(黄白线)都底背离。


猜你喜欢